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ABSTRACT

Time constraints, as well as ignorance of other business disciplines, often
preclude instructors from properly incorporating illustrations from outside their
area of expertise into their courses.  This can result in students having difficulty in
applying skills learned in one course to other courses.    We address this student
learning issue by showing how the skills and concepts students are learning in an
introductory Excel spreadsheet class can be applied to modern portfolio theory
using real data from Yahoo! Finance without mathematical and statistical
complexity.  By using a finance illustration in an information systems course,
students are better able to understand the value of the skills they are acquiring now
and how these skills will help them solve real-life problems.  Moreover, business
students who subsequently take an introductory finance course will be familiar with
one of finance’s most important theories. 

INTRODUCTION

Many business students have difficulty applying knowledge learned in one
class to other classes, especially if the class is not in their major discipline.
Professors often hear statements like the following from students, “I’m a finance
major, why do I need to know something about information systems.”  For these
students there is a no connection of how the concepts and skills learned in one class
can help them solve problems in another class.  In 2002 the Association of American
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Colleges and Universities published a report entitled Greater Expectations: A New
Vision for Learning as a Nation Goes to College that addresses this student learning
issue.  The report states the following “Once enrolled in College, students face …
barriers to excellence.  The fragmentation of the curriculum into a collection of
independently “owned” courses is itself an impediment to student accomplishment,
because the different courses students take, even on the same campus, are not
expected to engage or build on one another.  Few maps exist to help students plan
or integrate their learning as they move in and out of separately organized courses,
programs, and campuses.  In the absence of shared learning goals and clear
expectations, a college degree more frequently certifies completion of disconnected
fragments than of a coherent plan for student accomplishment.”  The Association of
Advance Collegiate Schools of Business (AACSB International) expresses similar
student learning concerns in their 2003 Eligibility Procedures and Standards for
Business Accreditation.  This AACSB publication promotes cross-functional
integration within business programs.  We address this student learning issue by
showing how students can apply finance’s modern portfolio theory using real data
in an introductory Excel spreadsheet class.

1990 Nobel Prize winner in economics, Harry Markowitz (1952), is credited
with developing modern portfolio theory.  His work shows that the adage “don’t put
all your eggs in one basket” is sound advice.  In financial terms he shows that it is
possible for investors to combine financial assets (stocks) in such a way that it
increases their return while also decreasing their risk.  We show that students taking
an introductory Excel spreadsheet course can apply his work using real stock price
data from Yahoo! Finance.  By using a finance application in an information
systems class, students will understand how the skills and concepts they are learning
in an introductory Excel spreadsheet course can help them in other classes that are
often taken years later.  It also introduces students to the risk-return trade-off in
finance that investment and introductory finance courses cover in detail.  Moreover,
a number of finance textbooks use Excel to solve and illustrate problems.iii  Finally,
there are a growing number of financial modeling courses at universities and a
growing number of financial modeling textbooks that use Excel extensively.iv

The purpose of this paper is to show students how simple Excel functions
that they commonly learn in an introductory Excel spreadsheet class can help them
understand modern portfolio theory without mathematical and statistical complexity.
Having students simulate the process of portfolio construction will help them better
understand the decision process that money managers use in making their asset
allocation decisions. Using Excel’s solver and scenario manager students can
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perform a risk-return analysis in little time by developing an efficient frontier and
capital market line.v  First, Excel’s solver is a tool that optimizes a dependent
(output) variable by changing the values of independent (input) variable(s) subject
to some constraint(s).  Solver finds a new solution to the problem each time you
change the value of the dependent variable or the value of a constraint.  The solver
function is a part of Excel’s Solver add-in.  If this function is not currently available
under the Tools menu, it can be installed by loading the Solver add-in.  To do this,
go to the Tools menu and click Add-ins.  In the Add-Ins available list, select the
Solver box, and then click OK.  Second, scenario manager is a tool that can store
the solutions from solver.  Moreover, it provides a convenient way to summarize the
solutions that solver produces.  In addition to solver and scenario manager, students
will learn about naming cells and/or ranges, absolute and relative cell referencing,
basic functions such as average, stdev, and correl, paste special with several
optional features, and array formulas.

DOWNLOADING DATA AND COMPUTING RETURNS

To get free historical stock price data go to the following link
http://finance.yahoo.com/.  This is the home page for Yahoo! Finance.  In the
Market Summary section there are a number of stock indices listed, click on Dow
and a new page will appear.  On this page go to the More On section, click on
components.  This page contains an alphabetical listing of the 30 firms that comprise
the Dow Jones Industrial Index with their ticker symbols.vi As of December 14,
2005, Alcoa Inc. (symbol: AA) was the first firm.  The screen should look similar
to figure 1.

Figure 1
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Clicking on the first ticker symbol, AA, opens AA’s Yahoo! Finance home
page.  In the section More on AA click on historical prices.  In the set date range
select monthly.  In the start date select December 31, 2001.  In the end date select
December 31, 2004.  Now click on Get Prices.  Scroll down the page and select
Download to Spreadsheet.  Click on Save and in this case the ticker symbol is AA
so name the file AA.  By default the file will be saved as comma separated with the
file extension .csv.  Now select Open and an Excel worksheet that looks like figure
2 will appear.

Figure 2

Now select columns B:F by hovering the mouse over column B and holding
down the left mouse button while moving the mouse over to column F.  Release the
left mouse button and delete these columns by right clicking the mouse and selecting
delete.  Next, in cell B1 enter AA Prices and in cell C1 enter AA returns.

To compute monthly stock price changes in decimals for AA select cell C2
and enter the formula =B2/B3-1.  Copy this formula down to cell C37 by selecting
cell C2 and hovering the pointer over the lower right corner of cell C2 until it turns
into a black plus sign.  Hold down the left mouse button and drag to cell C37, then
release.  To save your file go to File>Save As.  In the file name enter AA and in the
Save as Type select Microsoft Excel Workbook by scrolling up.  The saved file will
look like figure 3.
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Figure 3

Repeat this process for the remaining 29 stocks left in the Dow index.
Remember to use the appropriate ticker symbols to name the files and for naming
price and return columns within each file.  To help organize the files it is probably
best to create two new folders.  One folder will contain .csv files with price data
downloaded from Yahoo! Finance and the other folder will contain .xls files that
have just dates, prices, and computed monthly stock returns.

Finally, to get a risk-free rate of return go to http://finance.yahoo.com/, enter
^IRX in the Enter Symbol(s) area and click on GO.  ̂ IRX is the ticker symbol for the
13-week U.S. treasury bill.  Use the same start dates and end dates as before and
name the .csv file using the ticker symbol when downloading the information.   Now
select Open and an Excel worksheet that looks like figure 4 will appear.

Delete columns B:F like before.  Next, in cell B1 enter ̂ IRX Annual Returns
and in cell C1 enter ^IRX Monthly Returns.  To compute monthly returns for ^IRX
select cell C2 and enter the formula =B2/(12*100).vii  Copy this formula down to cell
C37.  To save the file go to File>Save As.  In the file name enter ^IRX and in the
Save as Type select Microsoft Excel Workbook by scrolling up.  The saved file will
look like figure 5.
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Figure 4

 Figure 5

CREATING THE MASTER RETURN FILE

Currently there are 31 Excel files and we need to create one file that
contains the returns for all 30 firms in the Dow Jones and the 13-week U.S. treasury
security.  Start by opening Excel and select File>Save As. In the file name enter
master and select save.  Second, open the AA file with the .xls extension and select
column A.  Copy column A in the AA file to the master file by selecting Edit>Copy
from the menu bar and then select column A in the master Excel workbook and
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paste the column by selecting Edit>Paste.  Third, copy column C in the AA file to
the master file by selecting Edit>Copy from the menu bar and then select column
B in the master Excel workbook and paste the column by selecting Edit>Paste
Special>Values.  Pasting values changes the formulas in this cell range to numbers.
Fourth, close the AA file by going to the AA file and selecting File>Close.  

For the remaining .xls files containing returns do not repeat the copy process
for the dates.  However, repeat the copy process for the returns of the other 29 firms
and the 13-week U.S. treasury security.  For example, open the AIG file and select
column C.  This is the column that contains the returns for AIG.  Copy column C in
the AIG file to the master file by selecting Edit>Copy from the menu bar and then
select column C in the master Excel workbook and paste the column by selecting
Edit>Paste Special>Values.  Close the AIG file by going to the AIG file and
selecting File>Close.  Copy the returns of the remaining 28 firms and the 13-week
U.S. treasury security.  After copying the returns, the master Excel file will look like
figure 6.

Figure 6

RETURN STATISTICS

To create the efficient frontier and capital market line we need to compute
some summary statistics.  In cell A38 type the label Total Return, in cell A39 type
the label Annualized Return, in cell A40 type the label Std Dev of Monthly Returns,
and in cell A41 type the label Annualized Std Dev.viii  To compute the total return,
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select cell B38 and enter =PRODUCT(1+B2:B37)-1 while holding down the ctrl and
shift buttons on the keyboard.  Holding these two buttons down while hitting enter
will put brackets {} around the formula and this creates an array formula.  Copy this
formula across row 38 to cell AF38.  To compute the annualized return, select cell
B39 and enter =(1+B69)^(1/3)-1.  Copy this formula across row 39 to cell AF39.
To compute the std dev of monthly returns, select cell B40 and type =stdev(b2:b37).
Copy this formula across row 40 to cell AF40.  Finally, to compute the annualized
std. dev, select cell B41 and type =B40*SQRT(12).  Copy this formula across row
41 to cell AF41.

To help organize the workbook, rename Sheet1 by moving the pointer over
Sheet1 and right clicking the mouse.  A pop-up menu will appear and select rename.
Rename this worksheet by entering Returns.   Likewise, rename sheet2 to Portfolio.

EFFICIENT FRONTIER WORKSHEET-FORMATTING

To create the efficient frontier we need to enter some cell labels on the
Portfolio worksheet and compute some additional statistics.  Much of the work in
this section involves moving between the Returns worksheet and Portfolio
worksheet.  We begin by entering cell labels on the Portfolio worksheet and copying
statistics from the Returns worksheet to the Portfolio worksheet.

Go to the Portfolio worksheet and in cell A1 enter Asset, in cell B1 enter
Annualized Std Dev, and in cell C1 enter Annualized Return.  Now select the Returns
worksheet and highlight cells B1:AF1 and select Edit>Copy.  Go back to the
Portfolio worksheet, highlight cell A2 and paste this information by selecting
Edit>Paste Special.  Be sure to transpose the cell range and copy values.
Transposing a row of cells changes it into a column of cells.  Repeat this process for
the annualized standard deviation and annualized return.  For example, go to the
Returns worksheet, highlight the cell range B41:AF41, and select Edit>Copy.
Return to the Portfolio worksheet, select cell B2 and paste this information by
selecting Edit>Paste Special.  Be sure to transpose the cell range and copy values.
After copying the annualized return information, the Portfolio worksheet will look
like figure 7.

Next, we need to create three matrices on the Portfolio worksheet.ix  The
first matrix is for stock return correlations.  In cell A34 enter Correlation of Monthly
Stock Returns.  We first create labels for the 30 stocks in range A36:A65 by entering
a formula =A2 in cell A36 and then copy this formula to cell A65.  Be sure that you
don’t copy the 13-week treasury bill returns.  It is not needed for this matrix.  Next,
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we paste the labels we just created in the range A36:A65, a range aligned in a
column, to the range C35:AE35, a range aligned in a row.  We do this by selecting
the range A36:A65 and then go to Edit>Copy.  Next, move the cursor to cell B35,
and then go to Edit>Paste Special checking two options: Values and Transpose.
Figure 8 shows the results.

Figure 7

Figure 8

The second matrix is for stock return variances and covariances.  In cell A67
enter Variance-Covariance of Monthly Stock Returns.  Similar to the correlation
matrix, two identical sets of labels for the 30 stocks need to be created in range
A69:A98 and range B68:AE68, respectively.  Note, the 13-week treasury bill data
is not needed in this matrix either.  Figure 9 shows the results.



76

Journal of Economics and Economic Education Research, Volume 9, Number 3, 2008

Figure 9

The third matrix is needed to compute statistics for the portfolio of 30
stocks.  First create labels for the 30 stocks in ranges A69:A133 and C102:AF102,
respectively, using similar techniques.  Next, we create weights for each of the 30
stocks in a portfolio.  In cell B103 enter the label Weight.  In cell B104 enter =1/30
and copy this formula to cell B133.  The original portfolio is going to be equally
weighted.  Since there are 30 stocks in the portfolio, we will invest 1/30 in each
stock.  To change the formulas in this cell range to values highlight the cell range
B104:B133, select Edit>Copy>Edit>Paste Special, and select values.  We need to
change the formulas to values so that solver can find solutions in the following
section.  Next, we need to transpose the weights we just created in range B04:B133
to range C103:AF103. However, this time we use another technique instead of the
Edit>Paste Special used for the other two matrices.  Again, the reason for this is that
it is necessary step for solver to find solutions in the next section.  The new
technique uses the offset function in Excel. First, create auxiliary labels 1, 2, 3,
through 30, in range C100:AF100 as follows: in cell C100 enter 1, in cell D100
enter 2, then select both cells C100 and D100 and hover the pointer over the lower
right corner of cell D100 until it turns into a black plus sign, hold down the left
mouse button and drag to cell AF100.   Next, enter the formula
=offset($B$103,C100,0) in cell C103, and then copy the formula to AF103.   You
can check your formulas in the range C103:AF103 by changing a weight in the cell
range B104:B133.  For example, select cell B119.  This is the weight for JNJ and it
is currently set equal to 0.033333. Change this value by entering 0.10.  Now go to
cell R103 and the value should be 0.10. 

To finish labeling the Portfolio worksheet select cell A134 and enter Sum
of Weights; A135, enter Portfolio Variance; A136, enter Portfolio Standard
Deviation; A137, enter Portfolio Return; and A138, enter Capital Market Line.  Now



77

Journal of Economics and Economic Education Research, Volume 9, Number 3,  2008

that the cell labeling is finished we can proceed to computing statistics for the three
matrices.  Figure 10 shows the results.

Figure 10

EFFICIENT FRONTIER WORKSHEET-FORMULAS

On the Portfolio worksheet select cell B36 in the correlation matrix.  To
enter correlations select Insert>Function.  In the search for a function area type
correl, select Go, then OK.  This brings-up Excel’s correlation function, which is
named correl.  Select Array1 by moving the pointer to the spreadsheet symbol to the
right of the text box and right clicking the mouse.  Now select the Returns
worksheet, highlight the cell range B2:B37 and hit enter.  The following should
appear in the Array1 text box Returns!B2:B37.  Next, select Array2.  Now select the
Returns worksheet, highlight the cell range B2:B37, hit enter and click OK.  This
computes the correlation between AA and AA.  To increase efficiency change the
formula in cell B36 by entering dollar signs ($).  To do this, select cell B36 on the
Portfolio worksheet and go to the formula.  Currently the formula should read
=CORREL(Returns!B2:B37,Returns!B2:B37).  Change the formula so that it reads
=CORREL(Returns!$B2:$B37,Returns!B2:B37) and hit enter.  Copy the formula in
cell B36 to the cell range C36:AE36.  Repeat this process for the remaining cells.
For example, select cell B37 and go to Insert>Function.  The Correl function should
be highlighted under the section select a function so click OK.  If not, repeat the
process above.  Select Array1.  Now select the Returns worksheet, highlight the cell
range C2:C37 and hit enter.  The following should appear in the Array1 text box
Returns!C2:C37.  Next, select Array2.  Now select the Returns worksheet, highlight
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the cell range B2:B37, hit enter, and click OK.  Currently the formula should read
=CORREL(Returns!C2:C37,Returns!B2:B37).  Change it so that it reads
=CORREL(Returns!$C2:$C37,Returns!B2:B37).  Copy the formula in cell B37 to
the cell range C37:AE37.  Repeat this process for the remaining cells.x  The cell
formulas for the correlation matrix are in appendix A.

To enter the variances and covariances go to the Portfolio worksheet, select
cell B69, enter the formula =B36*B2*$B$2, and copy it down column B to cell B98.
Next, select cell C69 on the Portfolio worksheet, enter the formula =C36*B2*$B$3
and copy it down column C to cell C98.  Continue entering formulas in this manner
for columns D to AE.  In column AE, select cell AE69, enter the formula
=AE36*B2*$B$31, and copy it down column AE to cell AE98.  The cell formulas
for the variance-covariance matrix are in appendix B.

The last matrix is the border multiplied variance-covariance matrix.  We
need to compute values in this matrix so that we can compute the variance and
standard deviation for the portfolio.  Go to the Portfolio worksheet, select cell C104
and enter =$B104*C$103*B69.  Copy the formula in C104 to the range
C104:AF133. 

To finish entering formulas into the Portfolio worksheet select cell B134 and
enter =SUM(B104:B133).  Copy this formula across row 134 to cell AF134.  The
sum of weights should equal 1 in cell B134.  Continue computing portfolio statistics
by selecting cell B135 and entering =SUM(C134:AF134).  Third, select cell B136
and enter =B135^(1/2).  Fourth, select cell B137 and enter
=sum(B104:B133*C2:C31) while holding down the ctrl and shift buttons.  Again,
holding these two buttons down while entering a formula will put brackets {} around
the formula and this creates an array formula.  Fifth, select cell B138 and enter
=(B137-C32)/B136.  The cell formulas for the border multiplied variance-
covariance matrix are in appendix C.

Finally, we will change the names of some cells.  Changing the names of
these cells will make it easier to interpret results later on.  Go to the Portfolio
worksheet and select cell B134.  Just to the left of the formula bar where the formula
=SUM(B104:B133) appears is the cell reference B134.  Select this area, type
weights, and hit enter.  The name of this cell is now weights instead of B134.
Repeat this process for the following cells: name B135 variance, B136 std_dev,
B137 return, B138 CML, B32 rf_std, and C32 RF_return.



79

Journal of Economics and Economic Education Research, Volume 9, Number 3,  2008

ORIGINAL PORTFOLIO

The original portfolio is equally weighted and we will save this information
for this portfolio by saving it as a scenario.  To do this go to Tools>Scenarios and
select Add.  Name the scenario original portfolio and in the changing cells text box
enter B104:B133.  Select OK and a pop-up menu named scenario values will appear.
Make sure that all values in these cells are set equal to 0.033333 and select OK.  The
scenario manager will now have a new scenario named original portfolio.  Click
close. 

EFFICIENT FRONTIER 

To use solver go to Tools>Solver. In the select target cell input $B$135 and
in the Equal to: click Min.  Cell B135 is the output (dependent) variable.  In the By
Changing Cells enter $B$104:$B$133.  The cell range B104:B133 contain the input
(independent) variables that solver will change to minimize the variance of the
portfolio.  Next, we need to add constraints.

To add the constraints, select Add.  For the first constraint do the following.
In the cell reference input $B$134, select =, and in the Constraint input 1.  Click
Add.  For the second constraint, enter $B$137 in the cell reference, select =, and in
the Constraint input -0.10.  Click OK.  The solver parameters will look like figure
11.

Figure 11

To run solver click Solve.  If solver successfully finds a solution it will
return a screen similar to figure 12.
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Figure 12

To keep the solution, select Save Scenario and name the scenario r=-10%.
The save scenario screen will look like figure 13.  

Figure 13

Click OK.  We have just saved our first scenario!
To create more scenarios go to Tools>Solver and in the Subject to the

constraints section select return=-0.10 and click Change.  In the Constraint section
enter a new return value equal to -0.075 and click OK.  This will take you back to
the Solver Parameters screen.  Click Solve.  Solver will find a solution and just like
before select Save Scenario.  Name the scenario r=-7.5% and click OK.  Repeat this
process using the following return values: -0.05, -0.025, 0.00, 0.025, 0.05, 0.075,
0.10, 015, 0.20, 0.25,  0.30, 0.325, 0.35, 0.375, 0.40, 0.50, 0.60, 0.70, 0.80, 0.90 and
1.00.  We will graph these scenarios later.

CAPITAL MARKET LINE

To create the efficient frontier we specified a return and had solver
minimize the portfolio variance by changing the weight invested in each stock.  To
find the best capital market line we will have solver maximize the trade-off between
risk and return.  To do this we need to change some inputs in the solver parameters.
Go to the Portfolio worksheet and select Tools>Solver.  In the Set Target Cell
section select cell B138, and in the equal to section select Max.  Do not change the
By Changing Cells section.  The following should be entered in this section
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$B$104:$B$133.  Finally, in the subject to the Constraints section delete the
return= constraint.  The Solver Parameters screen will now look like figure 14.

Figure 14

Click Solve and select save scenario. Name the scenario MAX CML.

MINIMUM VARIANCE PORTFOLIO

To compute the minimum variance portfolio select the Portfolio worksheet
and go to Tools>Solver.  In the Set Target Cell section select cell B135 and in the
equal to section select min. The Solver Parameters screen will now look like figure
15.

Figure 15

Click Solve and select Save Scenario.  Name the scenario minimum
variance.
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SCENARIO MANAGER

Scenario manager stores all saved scenarios.  To access these scenarios go
to Tools>Scenarios and a screen that looks like figure 16 will appear.

Figure 16

Scrolling down the Scenarios section shows additional scenarios including
the MAX CML and minimum variance scenarios.  To graph these scenarios select
Summary and in the Results cells input the cell range B136:B138 and the cell range
B32:C32.  The Scenario Summary screen will look like figure 17.

Figure 17

Click OK and a new worksheet named Scenario Summary that looks like
figure 18 will appear.  This worksheet contains the information to graph the efficient
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frontier, capital market line, original portfolio, and minimum variance portfolio.
Positive weights are long positions and negative weights are short positions.xi

Figure 18

GRAPHING

To graph the efficient frontier go to Insert>Chart.  In the Chart type section
select XY (scatter).  In the Chart sub-type section select Scatter with data points
connected by smooth lines.  Click Next and select the Series tab.  In the series
section click Remove until this section is blank.  Now click Add.  Select X Values,
highlight the cell range F37:AB37 on the scenario summary worksheet and hit enter.
Next, select Y Values, highlight the cell range F38:AB38 on the scenario summary
worksheet and hit enter.  Name the series by entering Efficient Frontier in the Name
section.

To graph the capital market line click Add.  Select X Values and while
holding down the CTRL button, select cell AC40, then cell AC37 on the Scenario
summary worksheet and hit enter.  Select Y Values and while holding down the
CTRL button select cell AC41, then cell AC38 on the Scenario summary worksheet
and hit enter.  Name the series Capital Market Line.
To graph the minimum variance portfolio click Add.  Select X Values, then select
cell AD37 on the Scenario summary worksheet and hit enter.  Next, select Y Values,
then select cell AD38 on the Scenario summary worksheet and hit enter.  Name the
series Minimum Variance Portfolio.  

To graph the original portfolio click Add.  Select X Values by selecting cell
E37 on the Scenario summary worksheet and hit enter.  Next, select Y Values by
selecting cell E38 on the Scenario summary worksheet and hit enter.  Name the
series original portfolio.  Click Next.
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Finish the graph by selecting the Titles tab.  In the Chart Title section enter Efficient
Frontier, CML, and Min Var Portfolio, in the Value (x) axis section enter Standard
Deviation, and in the Value (Y) axis section enter Return.  Click Next and select as
new sheet.  Name the new sheet Graph and select Finish.

To extend the capital market line left click on the line to highlight it.  Now
right click and a screen like figure 19 will appear. 

Figure 19

Select Add Trendline.  Select the Type tab and in the Trend/Regression Type
highlight Linear.  Now select the Options tab.  In the Trendline name section select
Automatic, and enter 0.10 for forward under the Forecast section.  Click OK.  The
graph should look similar to figure 20.

Figure 20

Efficient Frontier, CML, and Min Var Portfolio
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INTERPRETING THE GRAPH

The minimum variance portfolio is the mixture of risky stocks that reduces
risk (standard deviation) to its lowest possible level.  Every portfolio at and above
the minimum variance portfolio is said to be on the efficient frontier and every
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portfolio below the minimum variance portfolio is said to be on the inefficient
frontier.  Notice that any investor choosing a portfolio on the inefficient frontier can
increase return without increasing risk (standard deviation) by moving to a portfolio
that lies directly above on the efficient frontier. 

The original portfolio, even though it is well diversified, is not efficiently
diversified.  By changing the weights invested in each stock we can significantly
increase the return of the portfolio while decreasing risk.  

The capital market line is the line that begins at the risk-free rate of return
and “just touches” the efficient frontier.  The point where the capital market line
touches the efficient frontier is a special portfolio called the market portfolio.
Investors at this point, have 100 percent of their funds invested in the Dow Jones
index and 0 percent invested in the risk-free treasury bill.  Other investors might be
more risk averse and want to invest a portion of their funds in the risk-free treasury
bill.  They can accomplish this by lending (investing) some funds at the risk-free
rate.  Some investors might be so risk averse that they invest 100 percent in the risk-
free treasury bill and 0 percent in the market portfolio.  In this case, these investors
will be at the point on the capital market line that intersects the y-axis.

Finally, notice that all investors will invest in some combination of the
market portfolio and risk-free treasury bill.  To illustrate this, suppose that some
investor chose to invest in the minimum variance portfolio.  Interestingly, this
investor can increase return without increasing risk by alternatively investing X
percent in the market portfolio and (1-X) percent in the risk-free treasury bill, and
reach a point on the capital market line that is directly above the minimum variance
portfolio.

WHAT IF

Suppose the risk-free rate of return changes.  For example, suppose the
United States Federal Reserve performs some open market operations over a period
of time that causes the current risk-free rate of 0.0133…in cell C32 of the Portfolio
worksheet to change to 0.075.  Input the new risk-free rate in cell C32 and use solver
to maximize the capital market line in cell B138 just like before.  Excel will find a
new solution.  Save the scenario as before and give it the name NEW MAX CML to
differentiate it from the original MAX CML scenario.  Finally, perform a scenario
summary like before.  All of the original scenarios will appear plus the new one.
Graph the NEW MAX CML with all of the other original information to see how the
line changes. 
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CONCLUSION

We show that the skills students learn while in an introductory Excel
spreadsheet class can be applied to modern portfolio theory without mathematical
and statistical complexity.  By showing students how the skills and concepts they
are learning in a spreadsheet class can help them to understand concepts and
theories in other business disciplines (e.g. finance) we address a common student
learning issue.  Namely, we help students overcome a disconnect of how the
concepts and skills learned in one course can help them solve problems in another
course.  Furthermore, it introduces business students to the fundamental risk-return
trade-off in finance that investment and introductory finance courses cover in more
detail.  Introducing students to portfolio theory prior to taking the finance course
that most colleges of business require will help them better understand this
important concept.  Finally, this example helps instructors of introductory Excel
spreadsheet classes illustrate the value of the skills they are teaching to non-
information systems students.

TEACHING NOTES FOR THE CASE OF SIMULATING THE CHOICES
OF MONEY MANAGERS BY APPLYING MODERN PORTFOLIO

THEORY USING REAL STOCK PRICE DATA

CASE DESCRIPTION

As written, the audience for this case is business students who are taking an
introductory Excel spreadsheet class.  Nonetheless, this case can be adapted to other
courses in finance and investments at the undergraduate level.  Moreover, we use
this case at the M.B.A. level for students who are taking a pre-requisite spreadsheet
or finance course.  Most of these students have non-business undergraduate degrees
and have little or no spreadsheet skills or knowledge of finance theory.

This case is a ‘how to’ case and it simulates the process that a money
manager uses in selecting assets during portfolio construction.  In the introductory
Excel class we cover the case over multiple weeks as topics are covered in the
course.  This case becomes a major student project at this level and it illustrates how
the skills students learn in the course can be applied to another business discipline.
In undergraduate investment and finance courses we use this case as a part of a
semester project where students pick their own portfolio of stocks and get to decide
their weights individually.  We assign this part of the project as portfolio theory is
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discussed in class.  At the pre-requisite M.B.A. level we give students the case as
written and have them complete the case prior to discussing portfolio theory.  Since
these students have little or no spreadsheet skills or knowledge of finance theory,
it is helpful for these students to learn by doing.

This case has two specific learning objectives: (1) show students how the
skills they learn in one course can be applied to another course, and (2) increase
student spreadsheet skills and understanding of finance theory by simulating the
process that money managers use in putting together a portfolio of assets.  

CASE SYNOPSIS

This case places students in the role of a money manager who has the task
of putting together a portfolio of stocks that will minimize risk and maximize return.
Brinson, Singer, and Beebower (1991) show that asset allocation accounts for over
90 percent of the variation in portfolio returns.  Thus, portfolio construction and
management is one of the most important financial concepts.  This case shows
students how to construct a portfolio of stocks using real data from Yahoo! Finance.

ENDNOTES

iii Examples include Investments by Bodie, Kane, and Marcus, Essentials of
Investments by Bodie, Kane, and Marcus, Fundamentals of Financial Management
by Brigham and Houston, and Intermediate Financial Management by Brigham and
Daves.

iv Examples include Spreadsheet Modeling in Corporate Finance by Holden,
Spreadsheet Modeling in Investments by Holden, Financial Analysis with Microsoft
Excel 2002 by Mayes and Shank, and Financial Modeling Using Excel and VBA by
Sengupta.

v We will explain these terms later in the paper.
vi Excel’s scenario manager can handle up to 32 stocks in a portfolio.  Beyond 32

stocks, Excel issues an error message.
vii The Adj. Close* column for stocks is a stock price whereas the Adj. Close* column

for the 13-week U.S. Treasury bill is an annualized return in percent, not a bond
price.  One method to compute a monthly return for the bond is to divide the Adj.
Close* column by 12 and to change the return from percent to decimal by dividing
by 100.

viii Students should be familiar with arithmetic averages and standard deviations from
a math course in high school or a finite math or business statistics course in college.
This further emphasizes how skills learned in one class are used in another.
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ix Students should be familiar with matrices from their finite math course.  The use of
matrices in this project further emphasizes how skills learned in one class are used
in another.

x Adding a dollar sign in front of a row or column index makes the reference to that
row or column absolute instead of relative.  In this case, without using dollar signs
in the formulas for the correlation matrix, we would have to go through this process
900 times (30x30).  Using dollar signs reduces this number to only 30!

xi Shorting is a process where investors sell stock by borrowing it from another
investor, then replace the borrowed stock at a later date by buying it in the market,
hopefully at a lower price.
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Appendix B
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